CVE-2012-3587

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2012-3587
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2012-3587.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2012-3587
Published
2012-06-19T20:55:08Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import keyrings, relies on GnuPG argument order and does not check GPG subkeys, which might allow remote attackers to install Trojan horse packages via a man-in-the-middle (MITM) attack.

References

Affected packages

Debian:11 / apt

Package

Name
apt
Purl
pkg:deb/debian/apt?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.25

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / apt

Package

Name
apt
Purl
pkg:deb/debian/apt?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.25

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / apt

Package

Name
apt
Purl
pkg:deb/debian/apt?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.25

Ecosystem specific

{
    "urgency": "unimportant"
}