CVE-2012-5524

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2012-5524
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2012-5524.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2012-5524
Published
2014-02-08T00:55:05Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

The sslverifycallback function in tlsnb.py in Gajim before 0.15.3 does not properly verify SSL certificates, which allows remote attackers to conduct man-in-the-middle (MITM) attacks and spoof servers via an arbitrary certificate from a trusted CA.

References

Affected packages

Debian:11 / gajim

Package

Name
gajim
Purl
pkg:deb/debian/gajim?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.15.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / gajim

Package

Name
gajim
Purl
pkg:deb/debian/gajim?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.15.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / gajim

Package

Name
gajim
Purl
pkg:deb/debian/gajim?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.15.4-1

Ecosystem specific

{
    "urgency": "low"
}