CVE-2013-7322

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2013-7322
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2013-7322.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2013-7322
Published
2014-03-09T13:16:56Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

usersfile.c in liboath in OATH Toolkit before 2.4.1 does not properly handle lines containing an invalid one-time-password (OTP) type and a user name in /etc/users.oath, which causes the wrong line to be updated when invalidating an OTP and allows context-dependent attackers to conduct replay attacks, as demonstrated by a commented out line when using libpam-oath.

References

Affected packages

Debian:11 / oath-toolkit

Package

Name
oath-toolkit
Purl
pkg:deb/debian/oath-toolkit?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.1-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / oath-toolkit

Package

Name
oath-toolkit
Purl
pkg:deb/debian/oath-toolkit?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.1-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / oath-toolkit

Package

Name
oath-toolkit
Purl
pkg:deb/debian/oath-toolkit?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.1-1

Ecosystem specific

{
    "urgency": "low"
}