CVE-2014-10064

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2014-10064
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2014-10064.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2014-10064
Aliases
Published
2018-05-31T20:29:00Z
Modified
2024-06-30T12:01:22Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply nested object will block the event loop for long periods of time. An attacker could leverage this to cause a temporary denial-of-service condition, for example, in a web application, other requests would not be processed while this blocking is occurring.

References

Affected packages

Debian:11 / node-qs

Package

Name
node-qs
Purl
pkg:deb/debian/node-qs?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.4-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / node-qs

Package

Name
node-qs
Purl
pkg:deb/debian/node-qs?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.4-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / node-qs

Package

Name
node-qs
Purl
pkg:deb/debian/node-qs?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.4-1

Ecosystem specific

{
    "urgency": "unimportant"
}