CVE-2015-8630

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2015-8630
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2015-8630.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2015-8630
Published
2016-02-13T02:59:01Z
Modified
2024-05-14T04:53:12.033411Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The (1) kadm5createprincipal3 and (2) kadm5modifyprincipal functions in lib/kadm5/srv/svrprincipal.c in kadmind in MIT Kerberos 5 (aka krb5) 1.12.x and 1.13.x before 1.13.4 and 1.14.x before 1.14.1 allow remote authenticated users to cause a denial of service (NULL pointer dereference and daemon crash) by specifying KADM5_POLICY with a NULL policy name.

References

Affected packages

Alpine:v3.4 / krb5

Package

Name
krb5
Purl
pkg:apk/alpine/krb5?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.14-r1

Affected versions

1.*

1.11-r0
1.11-r1
1.11-r2
1.11.2-r0
1.11.2-r1
1.11.2-r2
1.11.3-r0
1.11.4-r0
1.12.1-r0
1.12.2-r0
1.13-r0
1.13-r1
1.13.1-r0
1.13.1-r1
1.13.2-r0
1.13.2-r1
1.13.2-r2
1.14-r0