CVE-2016-3861

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2016-3861
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-3861.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2016-3861
Published
2016-09-11T21:59:03Z
Modified
2024-06-30T12:01:22Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

LibUtils in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, 6.x before 2016-09-01, and 7.0 before 2016-09-01 mishandles conversions between Unicode character encodings with different encoding widths, which allows remote attackers to execute arbitrary code or cause a denial of service (heap-based buffer overflow) via a crafted file, aka internal bug 29250543.

References

Affected packages

Debian:11 / android-platform-system-core

Package

Name
android-platform-system-core
Purl
pkg:deb/debian/android-platform-system-core?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:7.0.0+r1-4

Ecosystem specific

{
    "urgency": "unimportant"
}