CVE-2016-5714

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2016-5714
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-5714.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2016-5714
Published
2017-10-18T18:29:00Z
Modified
2024-06-06T11:49:19.811394Z
Severity
  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

Puppet Enterprise 2015.3.3 and 2016.x before 2016.4.0, and Puppet Agent 1.3.6 through 1.7.0 allow remote attackers to bypass a host whitelist protection mechanism and execute arbitrary code on Puppet nodes via vectors related to command validation, aka "Puppet Execution Protocol (PXP) Command Whitelist Validation Vulnerability."

References

Affected packages

Git / github.com/puppetlabs/puppet-agent

Affected ranges

Type
GIT
Repo
https://github.com/puppetlabs/puppet-agent
Events
Type
GIT
Repo
https://github.com/puppetlabs/puppetlabs-puppet_agent
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected

Affected versions

0.*

0.1.0
0.2.0

1.*

1.0.0
1.1.0
1.2.0
1.3.0
1.3.1
1.3.2
1.3.6
1.4.0
1.4.1
1.4.2
1.5.0
1.5.1
1.5.2
1.5.3
1.6.0
1.6.1
1.6.2
1.7.0