CVE-2016-6131

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2016-6131
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-6131.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2016-6131
Related
Published
2017-02-07T15:59:00Z
Modified
2024-06-30T12:01:22Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The demangler in GNU Libiberty allows remote attackers to cause a denial of service (infinite loop, stack overflow, and crash) via a cycle in the references of remembered mangled types.

References

Affected packages

Debian:11 / binutils

Package

Name
binutils
Purl
pkg:deb/debian/binutils?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.27.51.20161102-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / binutils

Package

Name
binutils
Purl
pkg:deb/debian/binutils?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.27.51.20161102-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / binutils

Package

Name
binutils
Purl
pkg:deb/debian/binutils?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.27.51.20161102-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:11 / ht

Package

Name
ht
Purl
pkg:deb/debian/ht?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.0+repack1-2

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / ht

Package

Name
ht
Purl
pkg:deb/debian/ht?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.0+repack1-2

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / ht

Package

Name
ht
Purl
pkg:deb/debian/ht?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.0+repack1-2

Ecosystem specific

{
    "urgency": "low"
}

Debian:11 / libiberty

Package

Name
libiberty
Purl
pkg:deb/debian/libiberty?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
20161017-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / libiberty

Package

Name
libiberty
Purl
pkg:deb/debian/libiberty?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
20161017-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / libiberty

Package

Name
libiberty
Purl
pkg:deb/debian/libiberty?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
20161017-1

Ecosystem specific

{
    "urgency": "low"
}