CVE-2016-6316

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2016-6316
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-6316.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2016-6316
Aliases
Related
Published
2016-09-07T19:28:10Z
Modified
2024-06-30T12:56:44.741770Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
[none]
Details

Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.

References

Affected packages

Debian:11 / rails

Package

Name
rails
Purl
pkg:deb/debian/rails?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:4.2.7.1-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / rails

Package

Name
rails
Purl
pkg:deb/debian/rails?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:4.2.7.1-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / rails

Package

Name
rails
Purl
pkg:deb/debian/rails?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:4.2.7.1-1

Ecosystem specific

{
    "urgency": "low"
}

Git / github.com/rails/rails

Affected ranges

Type
GIT
Repo
https://github.com/rails/rails
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected
Last affected

Affected versions

Other

list

v0.*

v0.10.0
v0.10.1
v0.11.0
v0.11.1
v0.12.0
v0.13.0
v0.13.1
v0.14.1
v0.14.3
v0.9.1
v0.9.2
v0.9.3
v0.9.4
v0.9.4.1
v0.9.5

v1.*

v1.1.0
v1.1.0_RC1
v1.1.1

v2.*

v2.0.0
v2.0.0_PR
v2.0.0_RC1
v2.0.0_RC2
v2.0.1
v2.1.0
v2.1.0_RC1
v2.2.0
v2.2.1
v2.3.0
v2.3.1
v2.3.2
v2.3.2.1

v3.*

v3.0.0
v3.0.0.beta.2
v3.0.0.beta.3
v3.0.0.beta1
v3.0.0.beta2
v3.0.0.beta3
v3.0.0.beta4
v3.0.0_RC
v3.0.0_RC2
v3.0.2
v3.0.3
v3.1.0
v3.1.0.beta1
v3.1.0.rc1
v3.1.0.rc3
v3.1.0.rc4
v3.1.0.rc5
v3.1.0.rc6
v3.1.0.rc7
v3.1.0.rc8
v3.1.1
v3.1.1.rc1
v3.1.1.rc2
v3.1.1.rc3
v3.1.2
v3.1.2.rc1
v3.1.2.rc2
v3.2.0
v3.2.0.rc1
v3.2.0.rc2
v3.2.1
v3.2.2
v3.2.2.rc1

v4.*

v4.0.0.beta1
v4.0.0.rc1
v4.0.1
v4.0.1.rc1
v4.0.1.rc2
v4.0.1.rc3
v4.0.1.rc4
v4.0.2
v4.0.3
v4.0.4
v4.0.4.rc1
v4.0.5
v4.1.0
v4.1.0.beta1
v4.1.0.beta2
v4.1.0.rc1
v4.1.0.rc2
v4.1.1
v4.1.2
v4.1.2.rc1
v4.1.2.rc2
v4.1.2.rc3
v4.2.0
v4.2.0.beta1
v4.2.0.beta4
v4.2.0.rc1
v4.2.0.rc2
v4.2.0.rc3
v4.2.1
v4.2.1.rc1
v4.2.1.rc2
v4.2.1.rc3
v4.2.1.rc4
v4.2.2

v5.*

v5.0.0
v5.0.0.beta1
v5.0.0.beta1.1
v5.0.0.beta2
v5.0.0.beta3
v5.0.0.beta4
v5.0.0.rc1
v5.0.0.rc2