CVE-2016-6793

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2016-6793
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-6793.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2016-6793
Published
2017-07-17T13:18:06Z
Modified
2024-05-30T00:09:05Z
Severity
  • 9.1 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H CVSS Calculator
Summary
[none]
Details

The DiskFileItem class in Apache Wicket 6.x before 6.25.0 and 1.5.x before 1.5.17 allows remote attackers to cause a denial of service (infinite loop) and write to, move, and delete files with the permissions of DiskFileItem, and if running on a Java VM before 1.3.1, execute arbitrary code via a crafted serialized Java object.

References

Affected packages

Git / github.com/apache/wicket

Affected ranges

Type
GIT
Repo
https://github.com/apache/wicket
Events