CVE-2016-9955

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2016-9955
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-9955.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2016-9955
Aliases
Related
Published
2017-02-17T02:59:14Z
Modified
2024-06-30T12:01:22Z
Severity
  • 6.3 (Medium) CVSS_V3 - CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H CVSS Calculator
Summary
[none]
Details

The SimpleSAMLXMLValidator class constructor in SimpleSAMLphp before 1.14.11 might allow remote attackers to spoof signatures on SAML 1 responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

References

Affected packages

Debian:11 / simplesamlphp

Package

Name
simplesamlphp
Purl
pkg:deb/debian/simplesamlphp?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.14.11-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / simplesamlphp

Package

Name
simplesamlphp
Purl
pkg:deb/debian/simplesamlphp?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.14.11-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / simplesamlphp

Package

Name
simplesamlphp
Purl
pkg:deb/debian/simplesamlphp?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.14.11-1

Ecosystem specific

{
    "urgency": "low"
}