CVE-2017-1000122

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-1000122
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-1000122.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-1000122
Published
2017-11-01T21:29:00Z
Modified
2024-06-30T12:01:22Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L CVSS Calculator
Summary
[none]
Details

The UNIX IPC layer in WebKit, including WebKitGTK+ prior to 2.16.3, does not properly validate certain message metadata, allowing a compromised secondary process to cause a denial of service (release assertion) of the UI process. This vulnerability does not affect Apple products.

References

Affected packages

Debian:11 / webkit2gtk

Package

Name
webkit2gtk
Purl
pkg:deb/debian/webkit2gtk?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.16.3-2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / webkit2gtk

Package

Name
webkit2gtk
Purl
pkg:deb/debian/webkit2gtk?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.16.3-2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / webkit2gtk

Package

Name
webkit2gtk
Purl
pkg:deb/debian/webkit2gtk?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.16.3-2

Ecosystem specific

{
    "urgency": "unimportant"
}