CVE-2017-11331

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-11331
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-11331.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-11331
Published
2017-07-31T13:29:00Z
Modified
2024-06-30T12:50:47.439997Z
Severity
  • 5.5 (Medium) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The wav_open function in oggenc/audio.c in Xiph.Org vorbis-tools 1.4.0 allows remote attackers to cause a denial of service (memory allocation error) via a crafted wav file.

References

Affected packages

Debian:11 / vorbis-tools

Package

Name
vorbis-tools
Purl
pkg:deb/debian/vorbis-tools?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

1.*

1.4.0-11
1.4.2-1
1.4.2-2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / vorbis-tools

Package

Name
vorbis-tools
Purl
pkg:deb/debian/vorbis-tools?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

1.*

1.4.2-1
1.4.2-2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / vorbis-tools

Package

Name
vorbis-tools
Purl
pkg:deb/debian/vorbis-tools?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

1.*

1.4.2-1
1.4.2-2

Ecosystem specific

{
    "urgency": "unimportant"
}