CVE-2017-11549

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-11549
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-11549.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-11549
Published
2017-07-31T13:29:01Z
Modified
2024-06-30T12:51:16.163775Z
Severity
  • 5.5 (Medium) CVSS_V3 - CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The play_midi function in playmidi.c in TiMidity++ 2.14.0 allows remote attackers to cause a denial of service (large loop and CPU consumption) via a crafted mid file. NOTE: CPU consumption might be relevant when using the --background option.

References

Affected packages

Debian:11 / timidity

Package

Name
timidity
Purl
pkg:deb/debian/timidity?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

2.*

2.14.0-8
2.14.0-8.1
2.14.0-8.2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / timidity

Package

Name
timidity
Purl
pkg:deb/debian/timidity?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

2.*

2.14.0-8.1
2.14.0-8.2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / timidity

Package

Name
timidity
Purl
pkg:deb/debian/timidity?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

2.*

2.14.0-8.1
2.14.0-8.2

Ecosystem specific

{
    "urgency": "unimportant"
}