CVE-2017-12441

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-12441
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-12441.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-12441
Published
2017-08-17T16:29:00Z
Modified
2024-06-30T12:52:13.783616Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The rowisempty function in base/4bitmap.c:274 in minidjvu 0.8 can cause a denial of service (invalid memory read and application crash) via a crafted djvu file.

References

Affected packages

Debian:11 / minidjvu

Package

Name
minidjvu
Purl
pkg:deb/debian/minidjvu?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

0.*

0.8.svn.2010.05.06+dfsg-6
0.8.svn.2010.05.06+dfsg-6.1~exp1
0.8.svn.2010.05.06+dfsg-6.1
0.8.svn.2010.05.06+dfsg-7

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / minidjvu

Package

Name
minidjvu
Purl
pkg:deb/debian/minidjvu?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

0.*

0.8.svn.2010.05.06+dfsg-6
0.8.svn.2010.05.06+dfsg-6.1~exp1
0.8.svn.2010.05.06+dfsg-6.1
0.8.svn.2010.05.06+dfsg-7

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / minidjvu

Package

Name
minidjvu
Purl
pkg:deb/debian/minidjvu?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

0.*

0.8.svn.2010.05.06+dfsg-6
0.8.svn.2010.05.06+dfsg-6.1~exp1
0.8.svn.2010.05.06+dfsg-6.1
0.8.svn.2010.05.06+dfsg-7

Ecosystem specific

{
    "urgency": "unimportant"
}