CVE-2017-15047

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-15047
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-15047.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-15047
Published
2017-10-06T04:29:00Z
Modified
2024-06-30T13:02:24.244111Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

The clusterLoadConfig function in cluster.c in Redis 4.0.2 allows attackers to cause a denial of service (out-of-bounds array index and application crash) or possibly have unspecified other impact by leveraging "limited access to the machine."

References

Affected packages

Debian:11 / redis

Package

Name
redis
Purl
pkg:deb/debian/redis?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4:4.0.2-5

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / redis

Package

Name
redis
Purl
pkg:deb/debian/redis?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4:4.0.2-5

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / redis

Package

Name
redis
Purl
pkg:deb/debian/redis?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4:4.0.2-5

Ecosystem specific

{
    "urgency": "unimportant"
}

Git / github.com/antirez/redis

Affected ranges

Type
GIT
Repo
https://github.com/antirez/redis
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected

Affected versions

1.*

1.3.6

2.*

2.2-alpha0
2.2-alpha1
2.2-alpha2
2.2-alpha3
2.2-alpha4
2.2-alpha5
2.2-alpha6
2.2.0-rc1
2.3-alpha0

3.*

3.0-alpha0

4.*

4.0-rc1
4.0-rc2
4.0-rc3
4.0.0
4.0.1
4.0.2

v1.*

v1.3.10
v1.3.11
v1.3.12
v1.3.7
v1.3.8
v1.3.9

v2.*

v2.0.0-rc1
v2.1.1-watch

Other

vm-playpen
with-deprecated-diskstore