CVE-2017-16138

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-16138
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-16138.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-16138
Aliases
Published
2018-06-07T02:29:03Z
Modified
2024-06-30T13:02:22.316482Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.

References

Affected packages

Debian:11 / node-mime

Package

Name
node-mime
Purl
pkg:deb/debian/node-mime?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / node-mime

Package

Name
node-mime
Purl
pkg:deb/debian/node-mime?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / node-mime

Package

Name
node-mime
Purl
pkg:deb/debian/node-mime?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Git / github.com/broofa/node-mime

Affected ranges

Type
GIT
Repo
https://github.com/broofa/node-mime
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v1.*

v1.2.10
v1.2.11
v1.2.5
v1.2.7
v1.2.8
v1.2.9
v1.3.0
v1.3.3
v1.3.4
v1.3.6
v1.4.0