CVE-2017-17531

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-17531
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-17531.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-17531
Published
2017-12-14T16:29:01Z
Modified
2024-06-30T12:01:22Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

gozilla.c in GNU GLOBAL 4.8.6 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL.

References

Affected packages

Debian:11 / global

Package

Name
global
Purl
pkg:deb/debian/global?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.6.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / global

Package

Name
global
Purl
pkg:deb/debian/global?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.6.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / global

Package

Name
global
Purl
pkg:deb/debian/global?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.6.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}