Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.32.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.44"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "fd2e081b947124c90bcd97bfc55e1a7f2ef41a74"
}
],
"source": "REFERENCES_COMMIT"
}
]
}