Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types in javax.imageio in XStream-based APIs (SECURITY-383).
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "2.44"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.32.2"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "a814154695e23dc37542af7d40cacc129cf70722"
}
],
"source": "REFERENCES_COMMIT"
}
]
}