CVE-2017-3164

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-3164
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-3164.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-3164
Aliases
Published
2019-03-08T21:29:00Z
Modified
2024-06-30T13:06:15.088766Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

Server Side Request Forgery in Apache Solr, versions 1.3 until 7.6 (inclusive). Since the "shards" parameter does not have a corresponding whitelist mechanism, a remote attacker with access to the server could make Solr perform an HTTP GET request to any reachable URL.

References

Affected packages

Debian:11 / lucene-solr

Package

Name
lucene-solr
Purl
pkg:deb/debian/lucene-solr?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

3.*

3.6.2+dfsg-24
3.6.2+dfsg-25
3.6.2+dfsg-26

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / lucene-solr

Package

Name
lucene-solr
Purl
pkg:deb/debian/lucene-solr?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

3.*

3.6.2+dfsg-26

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / lucene-solr

Package

Name
lucene-solr
Purl
pkg:deb/debian/lucene-solr?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

3.*

3.6.2+dfsg-26

Ecosystem specific

{
    "urgency": "unimportant"
}

Git / github.com/apache/lucene-solr

Affected ranges

Type
GIT
Repo
https://github.com/apache/lucene-solr
Events