CVE-2017-5842

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-5842
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-5842.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-5842
Related
Published
2017-02-09T15:59:01Z
Modified
2024-05-14T06:08:34.374535Z
Severity
  • 5.5 (Medium) CVSS_V3 - CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

The htmlcontexthandleelement function in gst/subparse/samiparse.c in gst-plugins-base in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds write) via a crafted SMI file, as demonstrated by OneNoteManager.smi.

References

Affected packages

Alpine:v3.4 / gst-plugins-base1

Package

Name
gst-plugins-base1
Purl
pkg:apk/alpine/gst-plugins-base1?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.3-r0

Alpine:v3.5 / gst-plugins-base1

Package

Name
gst-plugins-base1
Purl
pkg:apk/alpine/gst-plugins-base1?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.3-r0

Affected versions

1.*

1.0.0-r0
1.0.1-r0
1.0.2-r0
1.0.3-r0
1.0.4-r0
1.0.5-r0
1.0.6-r0
1.0.7-r0
1.0.8-r0
1.0.9-r0
1.0.10-r0
1.2.0-r0
1.2.1-r0
1.2.2-r0
1.2.3-r0
1.2.4-r0
1.4.0-r0
1.4.1-r0
1.4.2-r0
1.4.3-r0
1.4.4-r0
1.5.2-r0
1.6.1-r0
1.6.3-r0
1.8.0-r0
1.8.1-r0
1.8.1-r1
1.8.1-r2

Git / github.com/gstreamer/gstreamer

Affected ranges

Type
GIT
Repo
https://github.com/gstreamer/gstreamer
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected