CVE-2017-7892

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-7892
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-7892.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-7892
Published
2017-04-17T21:59:00Z
Modified
2024-06-30T12:53:38.026717Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

Sandstorm Cap'n Proto before 0.5.3.1 allows remote crashes related to a compiler optimization. A remote attacker can trigger a segfault in a 32-bit libcapnp application because Cap'n Proto relies on pointer arithmetic calculations that overflow. An example compiler with optimization that elides a bounds check in such calculations is Apple LLVM version 8.1.0 (clang-802.0.41). The attack vector is a crafted far pointer within a message.

References

Affected packages

Debian:11 / capnproto

Package

Name
capnproto
Purl
pkg:deb/debian/capnproto?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / capnproto

Package

Name
capnproto
Purl
pkg:deb/debian/capnproto?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / capnproto

Package

Name
capnproto
Purl
pkg:deb/debian/capnproto?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Git / github.com/capnproto/capnproto

Affected ranges

Type
GIT
Repo
https://github.com/capnproto/capnproto
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected

Affected versions

v0.*

v0.5.0
v0.5.1
v0.5.1.1
v0.5.1.2
v0.5.2
v0.5.3