CVE-2017-9268

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2017-9268
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-9268.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2017-9268
Published
2018-03-01T20:29:00Z
Modified
2024-06-04T05:17:47.559884Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

In the open build service before 201707022 the wipetrigger and rebuild actions checked the wrong project for permissions, allowing authenticated users to cause operations on projects where they did not have permissions leading to denial of service (resource consumption).

References

Affected packages

Debian:12 / open-build-service

Package

Name
open-build-service
Purl
pkg:deb/debian/open-build-service?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / open-build-service

Package

Name
open-build-service
Purl
pkg:deb/debian/open-build-service?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.4-1

Ecosystem specific

{
    "urgency": "low"
}

Git / github.com/opensuse/open-build-service

Affected ranges

Type
GIT
Repo
https://github.com/opensuse/open-build-service
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected

Affected versions

1.*

1.9.90
1.9.91
1.9.92

2.*

2.3.60
2.3.90
2.3.91
2.4.50
2.4.51
2.5.50
2.8.0
2.8.1
2.8.2