CVE-2018-1308

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2018-1308
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1308.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2018-1308
Aliases
Related
Published
2018-04-09T13:29:00Z
Modified
2024-05-29T23:34:56Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

References

Affected packages

Git / github.com/apache/lucene-solr

Affected ranges