An issue was discovered in the Source Integration plugin before 1.5.9 and 2.x before 2.1.5 for MantisBT. A cross-site scripting (XSS) vulnerability in the Manage Repository and Changesets List pages allows execution of arbitrary code (if CSP settings permit it) via repo_manage_page.php or list.php.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:mantisbt:source_integration:*:*:*:*:*:mantisbt:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.5.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:mantisbt:source_integration:*:*:*:*:*:mantisbt:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.1.5"
}
],
"source": "CPE_RANGE"
},
{
"original_tag": "v1.5.9",
"range": [
{
"fixed": "b37c66556088cfafe1982e2bcb0019ef5e7008b7"
}
],
"source": "REFERENCES_TAG"
},
{
"original_tag": "v2.1.5",
"range": [
{
"fixed": "faac1b95f24bc329142b53d9a5f899c924113816"
}
],
"source": "REFERENCES_TAG"
}
]
}