CVE-2018-16861

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2018-16861
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-16861.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2018-16861
Published
2018-12-07T19:29:00Z
Modified
2024-05-30T01:42:58.318017Z
Severity
  • 4.8 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
[none]
Details

A cross-site scripting (XSS) flaw was found in the foreman component of satellite. An attacker with privilege to create entries using the Hosts, Monitor, Infrastructure, or Administer Menus is able to execute a XSS attacks against other users, possibly leading to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Foreman before 1.18.3, 1.19.1, and 1.20.0 are vulnerable.

References

Affected packages

Git / github.com/theforeman/foreman

Affected ranges

Type
GIT
Repo
https://github.com/theforeman/foreman
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Type
GIT
Repo
https://github.com/theforeman/foreman-installer
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Type
GIT
Repo
https://github.com/theforeman/smart-proxy
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

0.*

0.1
0.1-1
0.1-2
0.1-3
0.1-4
0.1-5
0.1-6
0.2
0.2rc1
0.2rc2
0.3
0.3.1
0.4
0.4rc2
0.4rc3
0.4rc4
0.4rc5

1.*

1.0
1.0.1
1.0RC1
1.0RC2
1.0RC3
1.0RC4
1.0RC5
1.1
1.18.0
1.18.0-RC1
1.18.0-RC2
1.18.0-RC3
1.18.1
1.18.2
1.1RC1
1.1RC2
1.1RC3
1.1RC4
1.1RC5