CVE-2018-20196

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2018-20196
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-20196.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2018-20196
Related
Published
2018-12-18T01:29:00Z
Modified
2024-06-04T05:24:18.974437Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

There is a stack-based buffer overflow in the third instance of the calculategain function in libfaad/sbrhfadj.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. A crafted input will lead to a denial of service or possibly unspecified other impact because the S_M array is mishandled.

References

Affected packages

Alpine:v3.10 / faad2

Package

Name
faad2
Purl
pkg:apk/alpine/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.0-r0

Affected versions

2.*

2.7-r0
2.7-r1
2.7-r2
2.7-r3
2.7-r4
2.7-r5
2.7-r6
2.7-r7
2.7-r8
2.8.8-r0

Alpine:v3.11 / faad2

Package

Name
faad2
Purl
pkg:apk/alpine/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.0-r0

Affected versions

2.*

2.7-r0
2.7-r1
2.7-r2
2.7-r3
2.7-r4
2.7-r5
2.7-r6
2.7-r7
2.7-r8
2.8.8-r0

Alpine:v3.7 / faad2

Package

Name
faad2
Purl
pkg:apk/alpine/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.0-r0

Affected versions

2.*

2.7-r0
2.7-r1
2.7-r2
2.7-r3
2.7-r4
2.7-r5
2.7-r6
2.7-r7

Alpine:v3.8 / faad2

Package

Name
faad2
Purl
pkg:apk/alpine/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.0-r0

Affected versions

2.*

2.7-r0
2.7-r1
2.7-r2
2.7-r3
2.7-r4
2.7-r5
2.7-r6
2.7-r7
2.7-r8

Alpine:v3.9 / faad2

Package

Name
faad2
Purl
pkg:apk/alpine/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9.0-r0

Affected versions

2.*

2.7-r0
2.7-r1
2.7-r2
2.7-r3
2.7-r4
2.7-r5
2.7-r6
2.7-r7
2.7-r8

Debian:11 / faad2

Package

Name
faad2
Purl
pkg:deb/debian/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.8.8-3.1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / faad2

Package

Name
faad2
Purl
pkg:deb/debian/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.8.8-3.1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / faad2

Package

Name
faad2
Purl
pkg:deb/debian/faad2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.8.8-3.1

Ecosystem specific

{
    "urgency": "low"
}

Git / github.com/knik0/faad2

Affected ranges

Type
GIT
Repo
https://github.com/knik0/faad2
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected

Affected versions

Other

2_8_0
2_8_1
2_8_2
2_8_3
2_8_4
2_8_5
2_8_6
2_8_7
2_8_8
FAAD2_2_5
FAAD2_2_7
FAAD2_2_7_1
arelease
ver_2_0