CVE-2018-3847

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2018-3847
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-3847.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2018-3847
Published
2018-08-01T19:29:00Z
Modified
2024-06-30T12:01:22Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

Multiple exploitable buffer overflow vulnerabilities exist in image parsing functionality of the CFITSIO library version 3.42. Specially crafted images parsed via the library, can cause a stack-based buffer overflow overwriting arbitrary data. An attacker can deliver an FIT image to trigger this vulnerability and potentially gain code execution.

References

Affected packages

Debian:11 / cfitsio

Package

Name
cfitsio
Purl
pkg:deb/debian/cfitsio?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.430-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / cfitsio

Package

Name
cfitsio
Purl
pkg:deb/debian/cfitsio?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.430-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / cfitsio

Package

Name
cfitsio
Purl
pkg:deb/debian/cfitsio?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.430-1

Ecosystem specific

{
    "urgency": "low"
}