CVE-2018-7162

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2018-7162
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-7162.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2018-7162
Published
2018-06-13T16:29:01Z
Modified
2024-06-30T13:01:09.213402Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

All versions of Node.js 9.x and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server to crash. This can be accomplished by sending duplicate/unexpected messages during the handshake. This vulnerability has been addressed by updating the TLS implementation.

References

Affected packages

Debian:11 / nodejs

Package

Name
nodejs
Purl
pkg:deb/debian/nodejs?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.15.0~dfsg-6

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / nodejs

Package

Name
nodejs
Purl
pkg:deb/debian/nodejs?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.15.0~dfsg-6

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / nodejs

Package

Name
nodejs
Purl
pkg:deb/debian/nodejs?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.15.0~dfsg-6

Ecosystem specific

{
    "urgency": "unimportant"
}

Git / github.com/nodejs/node

Affected ranges

Type
GIT
Repo
https://github.com/nodejs/node
Events

Affected versions

v10.*

v10.0.0
v10.1.0
v10.2.0
v10.2.1
v10.3.0
v10.4.0