CVE-2019-1010017

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2019-1010017
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-1010017.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2019-1010017
Aliases
Published
2019-07-15T03:15:10Z
Modified
2024-06-30T13:00:19.227831Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

libnmap < v0.6.3 is affected by: XML Injection. The impact is: Denial of service (DoS) by consuming resources. The component is: XML Parsing. The attack vector is: Specially crafted XML payload.

References

Affected packages

Debian:11 / python-libnmap

Package

Name
python-libnmap
Purl
pkg:deb/debian/python-libnmap?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.2-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / python-libnmap

Package

Name
python-libnmap
Purl
pkg:deb/debian/python-libnmap?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.2-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / python-libnmap

Package

Name
python-libnmap
Purl
pkg:deb/debian/python-libnmap?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.2-1

Ecosystem specific

{
    "urgency": "low"
}

Git / github.com/savon-noir/python-libnmap

Affected ranges

Type
GIT
Repo
https://github.com/savon-noir/python-libnmap
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

0.*

0.5.1

v0.*

v0.2
v0.2.1
v0.2.2
v0.2.3
v0.2.4
v0.2.5
v0.2.6
v0.2.7
v0.2.8
v0.2.9
v0.4.1
v0.4.2
v0.4.5
v0.4.6
v0.6
v0.6.1
v0.6.2