CVE-2019-1010304

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2019-1010304
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-1010304.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2019-1010304
Published
2019-07-15T15:15:11Z
Modified
2024-05-29T23:11:11Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
[none]
Details

Saleor Issue was introduced by merge commit: e1b01bad0703afd08d297ed3f1f472248312cc9c. This commit was released as part of 2.0.0 release is affected by: Incorrect Access Control. The impact is: Important. The component is: ProductVariant type in GraphQL API. The attack vector is: Unauthenticated user can access the GraphQL API (which is by default publicly exposed under /graphql/ URL) and fetch products data which may include admin-restricted shop's revenue data. The fixed version is: 2.3.1.

References

Affected packages

Git / github.com/mirumee/saleor

Affected ranges

Type
GIT
Repo
https://github.com/mirumee/saleor
Events