CVE-2019-12585

Source
https://cve.org/CVERecord?id=CVE-2019-12585
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-12585.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2019-12585
Published
2019-06-03T03:29:00Z
Modified
2026-10-20T10:51:37Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

Apcupsd 0.3.91_5, as used in pfSense through 2.4.4-RELEASE-p3 and other products, has an Arbitrary Command Execution issue in apcupsd_status.php.

Database specific
{
    "unresolved_ranges":  [
        {
            "cpes":  [
                "cpe:2.3:a:apcupsd:apcupsd:0.3.91_5:*:*:*:*:*:*:*"
            ],
            "extracted_events":  [
                {
                    "range":  [
                        {
                            "introduced":  "0.3.91_5"
                        },
                        {
                            "last_affected":  "0.3.91_5"
                        }
                    ],
                    "source":  "CPE_STRING"
                }
            ],
            "vendor_product":  "apcupsd:apcupsd"
        }
    ]
}
References

Affected packages

Git / github.com/pfsense/freebsd-ports

Affected ranges

Type
GIT
Repo
https://github.com/pfsense/freebsd-ports
Events
Database specific
Show details
{
    "extracted_events":  [
        {
            "cpe":  "cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "0"
                },
                {
                    "fixed":  "2.4.4"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:netgate:pfsense:2.4.4:-:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2.4.4-NA"
                },
                {
                    "last_affected":  "2.4.4-NA"
                }
            ],
            "source":  "CPE_STRING"
        },
        {
            "cpe":  "cpe:2.3:a:netgate:pfsense:2.4.4:p1:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2.4.4-p1"
                },
                {
                    "last_affected":  "2.4.4-p1"
                }
            ],
            "source":  "CPE_STRING"
        },
        {
            "cpe":  "cpe:2.3:a:netgate:pfsense:2.4.4:p2:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2.4.4-p2"
                },
                {
                    "last_affected":  "2.4.4-p2"
                }
            ],
            "source":  "CPE_STRING"
        },
        {
            "cpe":  "cpe:2.3:a:netgate:pfsense:2.4.4:p3:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2.4.4-p3"
                },
                {
                    "last_affected":  "2.4.4-p3"
                }
            ],
            "source":  "CPE_STRING"
        },
        {
            "range":  [
                {
                    "fixed":  "b492c0ea47aba8dde2f14183e71498ba207594e3"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        }
    ]
}

Affected versions

2.*
2.4.4-NA
2.4.4-p1
2.4.4-p2
2.4.4-p3
Other
END-OF-2015Q4
devel_before_hashes_changed

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-12585.json"