CVE-2019-15562

Source
https://cve.org/CVERecord?id=CVE-2019-15562
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-15562.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2019-15562
Published
2019-08-26T13:15:11Z
Modified
2026-10-20T10:50:45Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

GORM before 1.9.10 allows SQL injection via incomplete parentheses. NOTE: Misusing Gorm by passing untrusted user input where Gorm expects trusted SQL fragments is a vulnerability in the application, not in Gorm

References

Affected packages

Git / github.com/jinzhu/gorm

Affected ranges

Type
GIT
Repo
https://github.com/jinzhu/gorm
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Database specific
Show details
{
    "extracted_events": [
        {
            "cpe": "cpe:2.3:a:gorm:gorm:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "0"
                },
                {
                    "fixed": "1.9.10"
                }
            ],
            "source": "CPE_RANGE"
        },
        {
            "original_tag": "v1.9.10",
            "range": [
                {
                    "fixed": "836fb2c19d84dac7b0272958dfb9af7cf0d0ade4"
                }
            ],
            "source": "REFERENCES_TAG"
        }
    ]
}

Affected versions

v1.*
v1.0
v1.9
v1.9.1
v1.9.2
v1.9.3
v1.9.4
v1.9.5
v1.9.6
v1.9.7
v1.9.8
v1.9.9

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-15562.json"