CVE-2019-17221

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2019-17221
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17221.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2019-17221
Aliases
Published
2019-11-05T14:15:13Z
Modified
2024-06-30T13:10:01.138806Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

PhantomJS through 2.1.1 has an arbitrary file read vulnerability, as demonstrated by an XMLHttpRequest for a file:// URI. The vulnerability exists in the page.open() function of the webpage module, which loads a specified URL and calls a given callback. An attacker can supply a specially crafted HTML file, as user input, that allows reading arbitrary files on the filesystem. For example, if page.render() is the function callback, this generates a PDF or an image of the targeted file. NOTE: this product is no longer developed.

References

Affected packages

Git / github.com/ariya/phantomjs

Affected ranges

Type
GIT
Repo
https://github.com/ariya/phantomjs
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Last affected

Affected versions

1.*

1.0.0
1.1.0
1.9.0

2.*

2.0.0
2.1.0
2.1.1