CVE-2019-25101

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2019-25101
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-25101.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2019-25101
Aliases
Published
2023-02-04T08:15:07Z
Modified
2024-05-23T01:19:21.001391Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

A vulnerability classified as critical has been found in OnShift TurboGears 1.0.11.10. This affects an unknown part of the file turbogears/controllers.py of the component HTTP Header Handler. The manipulation leads to http response splitting. It is possible to initiate the attack remotely. Upgrading to version 1.0.11.11 is able to address this issue. The patch is named f68bbaba47f4474e1da553aa51564a73e1d92a84. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220059.

References

Affected packages

Git / github.com/onshift/turbogears

Affected ranges

Type
GIT
Repo
https://github.com/onshift/turbogears
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v1.*

v1.0.11.1
v1.0.11.10
v1.0.11.14
v1.0.11.2
v1.0.11.3
v1.0.11.4
v1.0.11.5
v1.0.11.6
v1.0.11.7
v1.0.11.8
v1.0.11.9