Logstash versions before 7.4.1 and 6.8.4 contain a denial of service flaw in the Logstash Beats input plugin. An unauthenticated user who is able to connect to the port the Logstash beats input could send a specially crafted network packet that would cause Logstash to stop responding.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:elastic:logstash:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.8.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:elastic:logstash:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.4.1"
}
],
"source": "CPE_RANGE"
}
]
}