HashiCorp Nomad and Nomad Enterprise up to 0.10.4 contained a cross-site scripting vulnerability such that files from a malicious workload could cause arbitrary JavaScript to execute in the web UI. Fixed in 0.10.5.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:hashicorp:nomad:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.3"
},
{
"fixed": "0.10.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:*",
"range": [
{
"introduced": "0.3"
},
{
"fixed": "0.10.5"
}
],
"source": "CPE_RANGE"
}
]
}