CVE-2020-11052

Source
https://nvd.nist.gov/vuln/detail/CVE-2020-11052
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-11052.json
Aliases
Published
2020-05-07T21:15:11Z
Modified
2024-05-15T01:11:37.300120Z
Summary
[none]
Details

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

References

Affected packages

Git / github.com/sorcery/sorcery

Affected ranges

Type
GIT
Repo
https://github.com/sorcery/sorcery
Events
Introduced
0The exact introduced commit is unknown
Fixed

Affected versions

0.*

0.11.0

Other

show

v0.*

v0.1.0
v0.1.1
v0.1.2
v0.1.3
v0.1.4
v0.10.0
v0.10.1
v0.10.2
v0.10.3
v0.12.0
v0.13.0
v0.14.0
v0.2.0
v0.2.1
v0.3.0
v0.3.1
v0.4.0
v0.4.1
v0.4.2
v0.5.0
v0.5.1
v0.5.2
v0.5.21
v0.5.3
v0.5.30
v0.6.0
v0.6.1
v0.7.0
v0.7.1
v0.7.10
v0.7.11
v0.7.12
v0.7.13
v0.7.2
v0.7.3
v0.7.4
v0.7.5
v0.7.6
v0.7.7
v0.7.8
v0.7.9
v0.8.0
v0.8.1
v0.8.2
v0.8.3
v0.8.5
v0.8.6
v0.9.0