CVE-2020-13223

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2020-13223
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-13223.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2020-13223
Aliases
Published
2020-06-10T19:15:09Z
Modified
2024-05-30T02:19:23.967922Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

HashiCorp Vault and Vault Enterprise logged proxy environment variables that potentially included sensitive credentials. Fixed in 1.3.6 and 1.4.2.

References

Affected packages

Git / github.com/hashicorp/vault

Affected ranges

Type
GIT
Repo
https://github.com/hashicorp/vault
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

api/v1.*

api/v1.0.1
api/v1.0.2
api/v1.0.3
api/v1.0.4

sdk/v0.*

sdk/v0.1.10
sdk/v0.1.11
sdk/v0.1.12
sdk/v0.1.13
sdk/v0.1.8
sdk/v0.1.9

v0.*

v0.1.0
v0.1.1
v0.1.2
v0.10.0
v0.10.0-rc1
v0.10.1
v0.10.2
v0.10.3
v0.10.4
v0.11.0
v0.11.0-beta1
v0.11.1
v0.11.2
v0.11.3
v0.11.4
v0.2.0
v0.2.0.rc1
v0.3.0
v0.3.0-rc
v0.3.1
v0.4.0
v0.4.0-rc1
v0.4.0-rc2
v0.4.1
v0.5.0
v0.5.0-rc1
v0.5.0-rc1.1
v0.5.0-rc1.2
v0.5.0-rc2
v0.5.1
v0.5.2
v0.6.0
v0.6.0-beta1
v0.6.0-beta2
v0.6.0-rc1
v0.6.0-rebuild
v0.6.1
v0.6.1-rc1
v0.6.1-rc2
v0.6.1-rc3
v0.6.2
v0.6.3
v0.6.4
v0.6.5
v0.7.0
v0.7.0-beta1
v0.7.1
v0.7.2
v0.7.3
v0.8.0
v0.8.0-beta1
v0.8.0-rc1
v0.8.1
v0.8.2
v0.8.3
v0.9.0
v0.9.1
v0.9.2
v0.9.3
v0.9.4
v0.9.5
v0.9.6

v1.*

v1.0.0
v1.0.0-beta1
v1.0.0-beta2
v1.0.0-rc1
v1.0.1
v1.0.2
v1.0.3
v1.1.0
v1.1.0-beta1
v1.1.0-beta2
v1.1.1
v1.1.2
v1.2.0
v1.2.0-beta1
v1.2.0-beta2
v1.2.0-rc1