CVE-2020-15241

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2020-15241
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15241.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2020-15241
Aliases
Published
2020-10-08T21:15:10Z
Modified
2024-05-30T02:26:35.413414Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
[none]
Details

TYPO3 Fluid Engine (package typo3fluid/fluid) before versions 2.0.5, 2.1.4, 2.2.1, 2.3.5, 2.4.1, 2.5.5 or 2.6.1 is vulnerable to cross-site scripting when making use of the ternary conditional operator in templates like {showFullName ? fullName : defaultValue}. Updated versions of this package are bundled in following TYPO3 (typo3/cms-core) versions as well: TYPO3 v8.7.25 (using typo3fluid/fluid v2.5.4) and TYPO3 v9.5.6 (using typo3fluid/fluid v2.6.1).

References

Affected packages

Git / github.com/typo3/fluid

Affected ranges

Type
GIT
Repo
https://github.com/typo3/fluid
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

1.*

1.0.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.1.0
1.1.1

2.*

2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.1.0
2.1.1
2.1.2
2.2.0
2.3.0
2.3.1
2.3.2
2.3.3
2.3.4
2.4.0
2.5.0
2.5.1
2.5.2
2.5.3
2.5.4
2.6.0