CVE-2020-23911

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2020-23911
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-23911.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2020-23911
Published
2023-07-18T14:15:11Z
Modified
2024-06-30T13:03:07.889286Z
Severity
  • 5.5 (Medium) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

An issue was discovered in asn1c through v0.9.28. A NULL pointer dereference exists in the function defaulterror_logger() located in asn1fix.c. It allows an attacker to cause Denial of Service.

References

Affected packages

Debian:11 / asn1c

Package

Name
asn1c
Purl
pkg:deb/debian/asn1c?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

0.*

0.9.28+dfsg-3
0.9.28+dfsg-4
0.9.28+dfsg-5

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / asn1c

Package

Name
asn1c
Purl
pkg:deb/debian/asn1c?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

0.*

0.9.28+dfsg-5

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / asn1c

Package

Name
asn1c
Purl
pkg:deb/debian/asn1c?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

0.*

0.9.28+dfsg-5

Ecosystem specific

{
    "urgency": "unimportant"
}