JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:rabbitmq:jms_client:*:*:*:*:*:rabbitmq:*:*",
"range": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.15.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:rabbitmq:jms_client:*:*:*:*:*:rabbitmq:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.2.0"
}
],
"source": "CPE_RANGE"
},
{
"original_tag": "v1.15.2",
"range": [
{
"fixed": "df5a7fc2806ce3b2a84f1eee3921036fc700781f"
}
],
"source": "REFERENCES_TAG"
},
{
"original_tag": "v2.2.0",
"range": [
{
"fixed": "a017343d2193fb81fb41334f725d3b277ad9bf0b"
}
],
"source": "REFERENCES_TAG"
}
]
}