CVE-2020-5261

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2020-5261
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-5261.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2020-5261
Aliases
Published
2020-03-25T02:15:11Z
Modified
2024-05-30T02:42:10.579937Z
Severity
  • 6.8 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
[none]
Details

Saml2 Authentication services for ASP.NET (NuGet package Sustainsys.Saml2) greater than 2.0.0, and less than version 2.5.0 has a faulty implementation of Token Replay Detection. Token Replay Detection is an important defence in depth measure for Single Sign On solutions. The 2.5.0 version is patched. Note that version 1.0.1 is not affected. It has a correct Token Replay Implementation and is safe to use. Saml2 Authentication services for ASP.NET (NuGet package Sustainsys.Saml2) greater than 2.0.0, and less than version 2.5.0 have a faulty implementation of Token Replay Detection. Token Replay Detection is an important defense measure for Single Sign On solutions. The 2.5.0 version is patched. Note that version 1.0.1 and prior versions are not affected. These versions have a correct Token Replay Implementation and are safe to use.

References

Affected packages

Git / github.com/sustainsys/saml2

Affected ranges

Type
GIT
Repo
https://github.com/sustainsys/saml2
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v0.*

v0.1.0
v0.10.0
v0.11.0
v0.12.0
v0.13.0
v0.14.0
v0.15.0
v0.15.1
v0.16.0
v0.17.0
v0.17.1
v0.17.2
v0.18.0
v0.18.1
v0.19.0
v0.2.0
v0.20.0
v0.21.0
v0.21.1
v0.21.2
v0.22.0
v0.23.0
v0.24.0
v0.3.0
v0.4.0
v0.5.0
v0.5.2
v0.6.0
v0.6.2
v0.7.0
v0.7.2
v0.8.0
v0.9.0

v1.*

v1.0.0

v2.*

v2.0.0
v2.1.0
v2.2.0
v2.3.0
v2.4.0