CVE-2020-8447

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2020-8447
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-8447.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2020-8447
Published
2020-01-30T01:15:11Z
Modified
2024-06-06T13:20:11.086829Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

In OSSEC-HIDS 2.7 through 3.5.0, the server component responsible for log analysis (ossec-analysisd) is vulnerable to a use-after-free during processing of syscheck formatted msgs (received from authenticated remote agents and delivered to the analysisd processing queue by ossec-remoted).

References

Affected packages

Git / github.com/ossec/ossec-hids

Affected ranges

Type
GIT
Repo
https://github.com/ossec/ossec-hids
Events

Affected versions

2.*

2.8.1
2.8.2
2.9.0-beta01
2.9.0-beta02
2.9.0-beta03
2.9.0-beta04

3.*

3.0.0
3.0beta01
3.0beta02
3.0beta03
3.1.0
3.2.0
3.3.0
3.4.0
3.5.0

Other

snapshot/20150112

v2.*

v2.7
v2.7.1
v2.8.0
v2.9.0beta05