CVE-2020-9432

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2020-9432
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-9432.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2020-9432
Published
2020-02-27T23:15:13Z
Modified
2024-05-23T01:19:46.425565Z
Severity
  • 9.1 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
[none]
Details

opensslx509checkhost in lua-openssl 0.7.7-1 mishandles X.509 certificate validation because it uses luapushboolean for certain non-boolean return values.

References

Affected packages

Git / github.com/zhaozg/lua-openssl

Affected ranges

Type
GIT
Repo
https://github.com/zhaozg/lua-openssl
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

0.*

0.1.0
0.1.1
0.1.2
0.2.0
0.4.1
0.5.0
0.5.1
0.6.0
0.7.0
0.7.1
0.7.3
0.7.4
0.7.5-1
0.7.5-2
0.7.6
0.7.6-0
0.7.7-0
0.7.7-1

Other

C_HAPPY