CVE-2021-20187

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2021-20187
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-20187.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2021-20187
Aliases
Published
2021-01-28T19:15:13Z
Modified
2024-06-06T13:23:19.544939Z
Severity
  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

References

Affected packages

Git / github.com/moodle/moodle

Affected ranges

Type
GIT
Repo
https://github.com/moodle/moodle
Events

Affected versions

v3.*

v3.8.0
v3.8.1
v3.8.2
v3.8.3
v3.8.4
v3.8.5
v3.8.6