CVE-2021-21311

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2021-21311
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21311.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2021-21311
Aliases
Related
Published
2021-02-11T21:15:13Z
Modified
2024-05-30T02:47:55.076668Z
Severity
  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N CVSS Calculator
Summary
[none]
Details

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. adminer.php) are affected. This is fixed in version 4.7.9.

References

Affected packages

Git / github.com/vrana/adminer

Affected ranges

Type
GIT
Repo
https://github.com/vrana/adminer
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v3.*

v3.0.0
v3.0.1
v3.1.0
v3.2.0
v3.2.1
v3.2.2
v3.3.0
v3.3.1
v3.3.2
v3.3.3
v3.3.4
v3.4.0
v3.5.0
v3.5.1
v3.6.0
v3.6.1
v3.6.2
v3.6.3
v3.6.4
v3.7.0
v3.7.1

v4.*

v4.0.0
v4.0.1
v4.0.2
v4.0.3
v4.1.0
v4.2.0
v4.2.1
v4.2.2
v4.2.3
v4.2.4
v4.2.5
v4.3.0
v4.3.1
v4.4.0
v4.5.0
v4.6.0
v4.6.1
v4.6.2
v4.6.3
v4.7.0
v4.7.1
v4.7.2
v4.7.3
v4.7.4
v4.7.5
v4.7.7
v4.7.8