CVE-2021-22948

Source
https://cve.org/CVERecord?id=CVE-2021-22948
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-22948.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2021-22948
Published
2021-09-23T13:15:08Z
Modified
2026-10-24T10:30:29Z
Severity
  • 7.1 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N CVSS Calculator
Summary
[none]
Details

Vulnerability in the generation of session IDs in revive-adserver < 5.3.0, based on the cryptographically insecure uniqid() PHP function. Under some circumstances, an attacker could theoretically be able to brute force session IDs in order to take over a specific account.

References

Affected packages

Git / github.com/revive-adserver/revive-adserver

Affected ranges

Type
GIT
Repo
https://github.com/revive-adserver/revive-adserver
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Introduced
Last Affected
Database specific
Show details
{
    "extracted_events":  [
        {
            "cpe":  "cpe:2.3:a:revive-adserver:revive_adserver:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "0"
                },
                {
                    "fixed":  "5.3.0"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:revive-adserver:revive_adserver:5.3.0:rc1:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "5.3.0-rc1"
                },
                {
                    "last_affected":  "5.3.0-rc1"
                }
            ],
            "source":  "CPE_STRING"
        }
    ]
}

Affected versions

5.*
5.3.0-rc1
v5.*
v5.3.0-rc1

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-22948.json"