In Talkyard, regular versions v0.2021.20 through v0.2021.33 and dev versions v0.2021.20 through v0.2021.34, are vulnerable to Insufficient Session Expiration. This may allow an attacker to reuse the admin’s still-valid session token even when logged-out, to gain admin privileges, given the attacker is able to obtain that token (via other, hypothetical attacks)
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:talkyard:talkyard:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.2021.20"
},
{
"fixed": "0.2021.35"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "b0310df019887f3464895529c773bc7d85ddcf34"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "b0712915d8a22a20b09a129924e8a29c25ae5761"
}
],
"source": "REFERENCES_COMMIT"
}
]
}